Movie clip symbols To make a simple button

1 Draw a shape on a new Stage, select it and choose Modify > Convert to Symbol...

Movie clips are the most complex and vseful type of symbol. They are really mini-movies,

iy e : . - e d B iour.
with timelines of their own, which play inside the main Timelirne. 2 Enter any name and choosc Button as the behaviour

3 Double-click the button to edit the symbol. You could also double-click it in the
Library window to edit it,

They also have the added benefit of being able to be scripted using ActionScript.

Everything that you do in the main Timeline, you can do inside a Movie clip too. Movie

- clips allow you to build animations within animations—for example, a shape tween Click inside the Over f dch the col b fih pic R "

i . N . . . v .

ik playing inside a motion tween (perhaps a cloud changing shape as it travels across the sky). 3 ", cDm31 fe the Over frame and change the colour or shape of the graphic. Repeat for
: e Down frame,

4 Press F6three times to create duplicate frames for the Over, Down and Hit states.

Over

Tomake a simple animated Movie dlp : ¢ 'The Hitframe only needs to be changed if your button is an irregular shape. Flash will

In a new Flash file, make a rotating wheel. look for any block of solid colour as the Fit state (active area).

- Go back to the main scene and test the button by previewing your movie.
1 Draw a circle on the Stage, and punch some holes in it with the eraser tool { ‘ ) ‘
| This extra detail makes it casier to see the circle rotate (see right). | Buttons are most useful 1‘:lvhen actions (small pieces of code) are applied to control them.
R Select the object and choose Modify > Convert to Symbol..., make this into A This will be covered in chapter 4, ActionScripting
a Movie clip symbol and call it ‘wheel’. The graphic will have a light blue ; :
box (see far right). Common Libraries
3 Double-click the symbol to move into symbol-editing mode. The Timeline jElalsh provides somep r.e-mac.le }‘3uttons @ Working in the wrong mode?
. s e R inside Common Libraries. This library can
you see is now the Movie clip Timeline, not the main Timeline. You can sec Keep an eve on the Scene Menu
. . . G help you get started and show you how pan eye on 1 X
this by looking at the Scene Menu (see right). MainStage  Cumentsymbol - . 1o check you are in the right
] . il i o oo sophisticated some button graphics can mode—on the Stage for normal
4 You are going to apply a motion tween inside this Movie clip. Select the Movie dip’stimeline become. To sce them, choose Window > work, and in symbol-editing mode
1 graphic in frame 1 and convert it to a Graphic symbol. Call it ‘wheel_graphic’. e & 0 : Common Libraries > Buttons, 1f you want when editing Graphic, Movie clip
i}' 5 Press 6 at frame 20 to create a duplicate keyframe. to use one of these pre-built buttons, at buttans tube double and Button symbols.
Al . . . - £ : : T3 §
6 Click back in frame 1 and set a Mofion tween. Set the rotation to be CW this beginning stage, only use the ones with Jassic buttans -
(clockwise) and make it rotate once. regular button icons 4. £ Arcade buteons rom@ :
. reade b itor Main’ ¢ bal
7 Go back to the main Stage by clicking on Scene I (see far right). From the & wrnin ‘ ZLSSE aindage  fumentsymio
Library, drag and drop two more instances of this Movie clip on the main Stage. W buerd
Scale these with the Free Transform tool so they are slightly different sizes (see p— B e, tune
below right). ' =
8 'Test the movie now. Note that the main Timeline is still only one frame long, S
but tfhree other twenty-frame animations play continuously within that e P|" buttons
one frame.
9  Youll see that the wheel ‘stutters’ as it encounters frame 20 and then frame 1, which In this exercise, you will create some pill shaped buttons.
have exactly the same graphic on them. To fix this, edit your ‘wheel’ symbol by adding a 1 Inanew document, choose View > Rulers and then
keyframe at frame 19, then deleting frame 20 completely (shortcut: Shift-F5). drag from the left ruler to place a vertical guide on
Any edit that you make to the graphic symbol called ‘wheel_graphic’ will be applied to the the Stage (see right).
Movie clip symbol called ‘wheel” and to every instance of “wheel’ on the Stage. 2 Draw a circle with no outline and a radial greyscale
Note: This movie won’t play in Flash authoring mode. To preview it press ¥/Ctrl-Enter. fill. When you draw it, hold down the Option/Alt
key and drag out from guide line. This will draw
the circle from the centre {see right).
Button SymbOIS 3 With the circle seiected use the Gradient Mave centre point of gradient upwards
§ Transformation tool LE to position the centre
A button is a type of symbol that can have some simple reaction to user interaction. of the gradient higher, but still centred on the
ActionScript is added to make the button to start or stop the movie, or do some other ' guideline (see top far right).
useful job. Buttons have a four-frame Timeline separate from the main movie’s Titneline. & 4 Select almost half of the left side of the circle (see
The four button frames— or states—are: right) and hold down the Shift key while mo-ving it N
+  Up-—whenever the mouse is not over the button. leﬁ;“h thte;la.rr::)w keYSﬁin dti;e k.eyboard. This will Select almast half of the left Stretch out the tiny centre sEtrip
o L th . theb make sure that it stays fixed horizontally. side and move it left to fill the gap.
ver—when the mouse 1s over the button. 5 Select a very small vertical slice from the remaining ]
»  Down—when the button is clicked. piece and using the Free Transform Fill tool drag
s+ Hit—the clickable area of the button. the centre handie on the left hand side to stretch
You only ever sce the first three frames, Up, the piece to fill the gap {see above far right).

Over and Down, The Hit frame tells Flash which

parts of the button graphic are active.
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“'e Pill buttons cont...

6 Select the whole graphic and convert it to a Graphic symbol.

) Motion guide layers

Motion Guide layers let you draw paths that motion-tweened symbols can be animated
along. The path is drawn in the Motion Guide layer, then motion tweens in the layer below

7 Choose Modify > Convert to Symbol again but this time choose the Button option. : can follow the path.
Call this symbol ‘pill _button’
8 Double-click on the ‘pill_button’ symbol to enter symbol editing mode and create To create motion on a path

a keyframe for each button state. In a new file:

9 In the Over frame, select the instance of *pill_graphic’ and adjust its Color settings
in the Property Inspector. Set Color to Brightness and make the value —30% (see
below). Choose your own Brightness setting for the Down state.

1 Draw a ball and convert it into a Graphic symbol.

2 Add a keyframe at frame 25 and motion frame 1.

_ 3 Create a new Guide layer by clicking this symbol |#
o in the layers area. You will see the Motion Guide layer
! appear and the layer containing the graphic indent

‘ underneath it. An indented layer is affected by the

;, Motion Guide.

: 4 Set the Pencil tool to a bright pink thin stroke. In the
Pencil tool Options, set the stroke to ‘smooth’ In one
motion, draw a wavy line across the screen. This is the
motion guide. It will be invisible in the final movie.

5 Inframe 1, move the symbol so that its small empty
circular point is at the beginning of the pink line.

6 Inframe 24, repeat but move the Graphic symbol to the end of the line.
@ Pink guides?

7 Turn on Omnion Skinning (see above) or run the Playhead along the
o TN R . . . . . Use bright pink because it is
Use runtimie bitmap eqehing. Timeline to see if the guide layer is working, .
e ) bt . easiest to see, and you are less
Brightness ; . . likely to have pink graphics to
| : i : To create oriented motion on a path confuse it with. This is a good

Flash habit to get into.

10 Go back to the main Stage. Drop one instance of ‘pill_button’ onto the
Stage if it is not already there. In the Property Inspecior, give it a Tintin
the Color menu (see below).

This Motion Guide technique is really useful for guiding shapes which havea
front end and a back end, for example; planes, cars, arrows, birds, triangles.

1 Create a new file and in it create a motion tweened
graphic and a Motion Guide layer, just as you did above,
but this time use a graphic which has a front and a back.

11 Option/Alt-drag to create two copies of the button. Make sure the
buttons are aligned, either using View > Snapping > Snap to Objects or
using the Align window.

- RER;

D Blend b Normat e
T ) Use riaritinge Bl

12 Give each button a different Tint, so that it looks as if you have 3 2 Onf:e your graphic is successfully followmg the Motl(.m
different buttons Tint Guide, select the start of the tween and switch on Orient

to path in the Properties window (see right).
Exercise extension: Edit the ‘pill_graphic’ symbol now to add some sophistication.

For example, you may wish to add extra highlights, a drop shadow and an outline.
Look at Window > Common Libraries > Buttons for ideas.

3 You will also need to make sure, at the start and end of
the tween, that your shape is pointing in the direction
of where iU’s going to go (so that Flash knows which is

\. 1 = e e Ao, BE Vimes L sybe: [hvort 3L Rep
the front.). i hamas ) @.l')rlem'ta path; T Syne 7] Snags b sound silected
3 : ! . N0 €

— |
Troubleshooting Motion Guides Orenttopath  Snap

If the animation does not follow the path (and it often doesn’t), check the following:

Layer effects

5 guide layer o
Al tayers e e L
mask layer

There are two different layer effects. These effects are applied directly
to the layers to produce:

! *  The graphic symbol should ‘snap’ to the path. Move the graphic symbol slightly, the
empty circle visible in the centre of the symbol should be over the guide line. Turning
on the Snap option at the start of the tween (see above} may help.

« Mask layers—which hide and show other layers below.

+  Guide layers—which guide motion tweens on other layers. . o P +  The Guide layer should have one unbroken line on it, If you have drawn your guide in
' e two or more stages, Flash might see this as two separate guides.
Layer properties - + The Guide layer should not have a tween. It is the layer below that is tweened.
. . . S A Shew
'To Jook at or set the properties for a layer, double-click the layer icon : S = IR R : » The icon for the layer below should be indented slightly, showing it is controlted by the
to the left of the layer name. The Layer Properties dialog box pops up (see R %2‘:;?;”- SRR K motion Guide layer above.
: - T Cigededt BRERRTTRRT O
right), Here you can set the Type, S DMk e : + If your tween is set to Orient to path, make sure that both the starting and ending
S Maskad - - : . . . ' . . v
_ < D Fotdar: RS : instances are pointing in the ‘right direction.
" uitling colot: [E:} B R :
_ ) Vi tayer 45 stlines,
. .laycrhelght: m :
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Mask layers
A Mask layer is a hole through which underneath layers are visible. The @ Biue masks?
masked area is the ‘window’ through which other layers can be seen. Another good Flash habit s to
create bright blue masks, Like
To createa Mask iayer the motion guides, these are
1 Create a new file never seen in the final movie.
) 1t helps to have some colour
2 Using regular Static Text, write a word of your choosing {see below). coding like this when movies
This will be ‘revealed’ by the mask. get complex.
3 Make a new layer in the normal way.
4 Onit, create a bright blue circle and turn that circle into a
Graphic or Movie clip symbol.
s Motion tween the circle across the word over a duration of
about 25 frames (see right}.
6 Right-click the icon for the ‘mask’ layer and set its type to

7

be a Mask layer. Both the Mask layer and the Masked layer
will be locked. This allows you to see the mask in action.
If you need to edit either of those layers, just unlock them.
They will always appear properly in your final movie, even
if they are unlocked.

Preview your movie to see the final effect.

Limitations and muitiple layers

You can add more layers under a Mask or Guide layer to create sophisticated effects. Make
sure the layers are directly underneath each other and their type is set to Masked or Guided.

You cannot have a Guide layer that is also a Mask layer, or a layer that is controlled by both
a Guide layer and a Mask layer. It is not possible to create a mask that follows a path.

A58
Q}L

‘@ End frame

"3 Make another new layer and on it, create some Static Text

You will now create an end frame suitable for an animation using a mask:
1 Some graphics have been provided for you. Open the file called “end_frame.fla”

2 Create a new layer and on it, draw a rectangle which covers
the Stage, but which is filled with only 40% of any solid
colour. Use the Color window to set this semi-transparency
(see far right}.

Transparency setting

which says “The End” or something similar (see right). Add
any effects or fills to the text as you like.

4 Create one more new layer and in it, create a blue
circle in the centre of the movie. It doesn’t matter
how big it is.

5 Convert this circle into a Graphic or
Movie clip symbol.

¢ Motion tween this symbol so that it starts very small
(almost invisible) and over the duration of the scene,
enlarges so that it covers the entire movie (see right).

7 Finally, make this layer into a Mask layer, and make
sure that it is masking the two layers below it. To
make the mask affect the semi-transparent colour
layer aswell, drag it up and right slightly so that it
indents underneath the Mask layer (see right).
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Creating scenes

Scenes are an easy way to set up separate sections of 4 Flash animation. Scenes play
automatically in the order that they sit in the Scene panel.

When to use scenes

Use scenes when your Timeline is getting too busy— too many layers, or too many frames.
Scenes should only be used when you are making a linear animation, never for scripted,
interactive movies. The only exception to that rule is when you are making preloaders
{which will be explained in further detail in the ActionScripting chapter).

Naming and ordering scenes

The Scere window is where you can rename, reorder, add and delete scenes. [i ity Eomtpmantei scene s 1

Open it by using Window > Other Panels > Scene (see right). & title
= To add a scene, click the Add scene button. gl

+ Todelete a scene, click Delete scene. & credits
»  'Torename a scene, double-click the scene name and enter a new name.

+  To duplicate a scene, click Duplicate scene.

| T
+ To change the order of a scene in the movie, drag the scene up or down the list.  Duplicatescene  Add seene  Delete scene

Editing and previewing scenes

Quickly jump from one scene to another with the Scene drop-down menu in the top
right of the Stage (sce right). .

When you test a movie with 3/Ctrl-Enter, all scenes play. To play only the current S # main movie
scene, press $8-Option-Return/Ctrl-Alt-Enter. - credits .

1 Open up any movie you have created.
1 Create a new Sceneand call it ‘countdown’,

3 Make a frame-by-frame animation in this new scene. It should show the numbers
counting down, ‘5; ‘4, “3’ and so on down to zero.

4 Arrange the scenes in the Scene panel so that this new scene plays first.

Exercise extension: Add some graphics behirid the numbers for a more visually
interesting countdown effect.
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